Engine Display Popup screen is blocked off

After a computer upgrade I reinstalled the q400 v 1.21. When undocking the Engine display popup, a small part of the screen is covered. It looks like a black picture has been pasted over it. This only occurs with this popup, the other popup screens do not.
Does anyone know of a solution to this problem?


  • Not knowing anything about your configuration one can only assume at this point. Maybe its a font scaling issue? We have not had any reported issues of this nature in the past.

  • Hi!!

    The same thing happened to me last year and it still happens. I mentioned this problem in the forum, but I did not have a response http://majesticsoftware.com/forums/discussion/595/black-square-on-engine-display#latest

    I have tried to do a clean install of the P3D and the MJCQ-400, but with no results.

    Hope you can find the solution.


  • I missed your post my apologies, however this is not an issue they we can replicate. At least you gave the operating system and version of P3D in use.

    Have you tried updating to the most graphic video driver.... Not knowing what type of GPU is in use.

    It is more challenging to to replicate something when there is minimal information to provided by the user experiencing the issue.
  • Hello Krosswind. Thanks for your quick response.

    I was honestly very surprised when this problem appeared for no apparent reason. Since then, I have tried, as I have mentioned, to do a clean installation of P3D and MJCQ-400, update the P3D and Q-400 and update the graphics card drivers, but the problem still continues.
    My PC: Inte core i5-4690, 16 GB RAM, graphics card nVidia GeForce GTX1050 with driver version, HD Seagate 1TB. My operating system: Windows 10 professional, 64-bit, fully updated. P3D v4.5.14.34698. MJCQ-400 pro version with patch v1.020b (v1.021 have the same issue)

    Keep investigating.

    Greetings and take care

  • Hello Krosswind,
    Sorry for this late response, but I had to do some other things at home first.
    I did a computer upgrade with a clean installation of Windows 10.
    I made a cockpit setup and use three video cards (gtx 960, 550 and gt710) to control five monitors.
    GTX 960; T2GO with three monitors and 1 VGA monitor for the cpt instrument panels,
    GTX 550; 2 VGA monitors for the motor instrument panels and FMS
    GT 710; 1 display for the instrument panels of the First Officer.

    This problem did not occur with the previous installation version of the Q400, v 1.20, but with the last update and this new version 1.21 it keeps showing up.

    I start the plane from a cold and dark situation and when I 'undock' the screen, you see that when initializing the engine screen this box is already present.
    If you need any specific information please let me know.

  • No one has any idea how to solve this problem? :(
    Is the only solution to go back to version 1.20a? Surely this cannot be true ....

  • @daredevil
    There weren't any changes at all to the graphics from version 1.020. Would you be able to check that
    1. The black rectangle is present on each popup window
    2. Would be present as well with electrics off ?

    My suspicion is that some 3rd part software or an addon is attempting to output some information (FPS?) in the corners of the DirectX windows

    1. The black rectangle is present on each popup window

    No, It is only present on the Engine Display Popup in the 'undocked' mode.

    1. Would be present as well with electrics off ?

    Yes, It is barely to see, but look at the edge op the picture. You can see the black rectangle on the edge of the grey background.

    My suspicion is that some 3rd part software or an addon is attempting to output some information (FPS?) in the corners of the DirectX windows

    I turned all addons (GSX, SODE, ORBX lib. and objectflow2, FLAI) off and restarted the sim, but this didn't solve the problem.

    I hope this info help to solve this. Thanks in advanced

  • This issue has just appeared on my flight sim and like the other users it only appeared after a reinstall of Win10 version 2004 OS Build 19041.45, P3D and Q400 Pro (1.020b). I can concur that the "black square" appears only when the Engine Display Panel is undocked and as stated above when P3D and Q400 in vanilla state.

    My PC Specs i7-6700K, 16GB, GTX970 (Yes, I know the GPU is a bit long in the tooth, I'm currently negotiating with Senior Mgt for an upgrade!)

  • It happens the same to me!
  • It was working perfectly in v4.5, but in v5 shows that black square...
  • I don't believe this problem has anything to do with the graphics card. In version 1.20 I didn't have this problem, but with this version I do and I still use the same graphics cards.
    If no changes have been made to the textures then what is causing this black block? Is this something caused by Windows 10? This seems strong to me ... does anyone have any idea what could be the cause?

  • At this time we do not have a solution to the problem, as we are not able to replicate it. I am currently using 3 monitors for testing in v5 with win 10 ver 1909 and I am not having this issue as of yet.

    It's on our bug tracker and hope we can find a resolution sooner than later.
Sign In or Register to comment.