Panning stutter in PRO version

edited November 2021 in General

Hi, as per title i suffer from panning stuttering and stuttering during POV change.
It looks like there is small buffer and textures are to be loaded again causing stutters.
Apart of that, simulation is pretty smooth, and frames are solid as set.
Other study level planes are butter smooth without single stutter.
My sim is P3D5.2, no EA, fps set and locked at 30 frames in NVIDIA panel, ChasePlane in use.
Any hint would be great - thanks.



  • We have had about 3 user reports of this issue and have not been able to replicate the issue through countless trial scenarios.

    We have used non complex and complex airports along with other third party addons and or utilities with no results.

    Maybe some video of the issue and a detailed breakdown of the utilities and or scenery in use while experiencing this issue.

  • On the ground regardless of payware airport i use everything is butter smooth, stuttering starts when in the air.
    It looks like situation develops with time.
    Sorry to say but making movies is way off my abilities.
    During stuttering fps are rock solid at 30, no fluctuation at all.

  • edited November 2021
    • Are you using a third-party frame limiter program? If yes, then try disabling it or not using it when flying the Dash and test again.

    • In the sim, have you set frame rates to "Unlimited" or have you set them limited to some number (for example, 30 fps)? If you have a set a number, then change that to "Unlimited" and test again. If you have set "Unlimited", then change that to a number and test again.

    • If you have set them as limited to a number, is that number able to be divided evenly in to your monitor's currently set refresh rate? For example, if your monitor's currently set refresh rate is 60Hz and you have set a frame rate limit in your sim to be 30, or 20, then those can be divided evenly (60 / 30 = 2) and (60 / 20 = 3) ... but, if you have set a frame rate limit in your sim to be, say, 25, then that cannot be divided evenly (60 / 25 = 2.4 ... which is not an even number). You should aim to set a frame rate limit that can be divided evenly. (Note: Some monitor refresh rates are numbers that cannot easily be divided ... for example, my monitor's default is 75Hz. In that case, you would use an FPS limit in the sim of 25 [divides evenly by 3] ... but you may want higher than 25 in which case you can "do your best" and try 37 and 38 as the FPS limit numbers in the sim [trying to get as close as possible to divided "evenly" by 2 as you can]. I found 37 worked best for me when panning ... but I have since discovered that leaving my sim set to "Unlimited", instead of 37 actually gives me the best results).

    • In CPAN, what "Timing" are you using (the "Queue Timer" or the "Multimedia Timer")? Whichever one you are using, try the other and test. (Note: There was an issue introduced in the latest versions of Windows [Windows Update 2004 specifically] in which the "Queue Timer" got broken and the Dash 8 timings in flight got really slow with flight times to destination taking nearly twice as long as they should -- you should use the "Multimedia Timer" if your Dash suffers from this).

    • I don't use Chaseplane and therefore cannot really comment on it being a possible cause, but, I would suggest turning it off, running a test flight, and seeing if that could be the possible culprit.

    • I have a Nvidia graphics card. I am aware that frame rates can be limited in the Nvidia Control Panel. I did try doing that once and did not notice much difference in my sim. Therefore, I removed the limit I had set and left the option set to the default setting (I am at work at the moment, and cannot check, but I think the default setting is "Off"). I would suggest you remove the limit from the Nvidia Control Panel, set the default setting instead, and try testing again. I would be particularly careful of possible conflicts if using a setting in the Nvidia Control Panel and also, at the same time, using a frame rate limit setting in the sim - especially if those two settings were not the same. I would therefore make sure either both settings were the same, or, better, when using the sim I would prefer to use the sim's in-built limiter instead of Nvidia's Control Panel one. I realise that is no good if you want to use Nvidia's Control Panel limiter for other games, but you can set a "Game Profile" in the Nvidia Control Panel specifically for use with your Flight Simulator if you need to.

    These are the things I would check and run tests on. Maybe one of these suggestions will be of help. :smile:

  • edited November 2021

    A small addition to what I've written above. If you run your tests and decide you do want to stick with using the frame rate limiter within the Nvidia Control Panel, then, for the sim, the same "rule" applies that I mentioned in my previous post ... choose a limit number that is able to be divided evenly in to your monitor's currently set refresh rate. That should give the best results.

  • @freddy

    Thanks for the comprehensive breakdown, and hope this can/may shine some light on @Artur issue.


  • Freddy - i have set my 30fps in NVIDIA leaving P3D5 setting as 'unlimited'. Monitor refresh is 60Hz. As said i have rock solid 30 frames. In NVIDIA i have set 'adaptive vsync' as such gives me even better smoothness. As said my system is set and optimized in such way that every study level plane is butter smooth. CPAN timing is set for 'multimedia' as with 'queue' i had strange pauses. Honestly i am sure that stuttering is not caused by wrong and not properly optimized or set graphic options. Chase plane - no option for me to fly without it, so will not even try. Frame limiter by NVIDIA or built into P3D5 - i see no difference.

  • edited November 2021

    Considering the rock solid 30FPS and the "butter smoothness" with other study level aircraft, with the settings you have listed, you are right to think the stuttering is probably not caused by wrong or incorrectly optimized graphic options ... but, unless you run the tests, then you really cannot say that with any certainty.

    Remember, the simulator relies on compromise. For example, you may change a setting that results in a small variation in FPS and slightly less smoothness than "butter smoothness", but it's not even noticable when you fly and it results in the panning issue with the Dash now being gone. But you'll never know unless you bite the bullet, change some settings, and run some tests.

    Adaptive vsync you say? Hmmm. Personally, I'd start right there and change that to the default setting of "Use the 3D application setting". Remember, if you make a change, and see no difference or it makes things worse, you can always change back to the setting you previously had. It probably also wouldn't hurt to make sure the Nvidia driver is updated to the latest, if it isn't already.

Sign In or Register to comment.