'Lost' Control Panel (CPAN) File

I've had to reinstall my Dash Q400. It seems to be fine except the cpan file (control panel) seems to be missing. The syspan file is there. Can anyone suggest where it may be, or if it can be downloaded separately? Do I have to delete and reinstall again?


  • That does seem to be odd. If the CPAN.exe is missing from the CPAN folder located within the root folder of the "mjc8q400" then I would recommend uninstalling and reinstalling the Q400 (be sure to do so by disabling your Anti-virus, and then installing using Administrator Rights)

  • Hi kroswynd, and thank you. I did all that you suggested, and the flight deck opened with the gear lever 'cycling up and down - twice! I deleted again and reinstalled again, and it seems to be OK but the cpan 'assignments' have not activated after being applied (with the a/c reinstalled - as instructed). It, so far, will not open in anything but default mode, whereas I want to be 'ready to taxi' as standard. I'll keep trying and let you know if it resolves. Also I want to change the 'zoom' view, but I think I have a note somewhere about which file needs to be altered.

  • OK. I fixed the fsx.cfg to sort out the 'zoom' ("wide view aspect"). Unfortunately the Dash is still wrong: gear lever cycling, throttles advancing by themselves, yoke not centred. I'm going to have one more go at deleting and reinstalling the Dash, but may use up my allocation of downloads. Can that be waived, please?

  • Sounds like you are having a possible protection issue, which in most cases is driven by not installing using Admin Rights. Some possible solutions as you are using FSX

    1. Is the Dash being installed to the default path?

    2. Are you allowing both the DirectX and SimConnect files to be installed?

    3. If you think, you might have selected "No" when asked by FSX about trusting the gauge mjc84main.dll gauge, you will have to purge the trust record in the fsx.cfg.
      erase the following line : mjc84_main.DLL.

    4. If still no help: Make sure your FSX is of version SP2 (or acceleration).Please note, that SP1 patch must be installed before SP2 or Acceleration installation is attempted. Failure to do so might result in the problems running the Q400

    5. Install the Dash-8 with right click, "run as administrator" option from the same drive where your FSX is installed

    6. Attempt running the FSX itself with the "run as administrator" option to bypass any possible file access problems

    7. If still not working, upgrade your Direct X from the microsoft web site http://www.microsoft.com/en-us/download/details.aspx?id=8109 to install please unzip the package to a location on the hard drive and run the included exe file.

    8. Make sure you don't have a USB sound device (aka headset) set as your primarily sound playback device in Windows

    9. Dash-8 might also be sensitive to your sound card drivers, or the speaker configuration, due to the utilization of DirectX sound effects. We suggest checking if you can update the drivers. Especially this seem to apply to Realtek sound devices

    If the installations become exhausted, then simply write to Support with the reason for the exhausted installs (you can even provide this thread), along with your user credentials used for the purchase of the Q400.

  • Thanks very much again, Kroswynd. I think, pretty much, all the things you suggest have been checked (e.g. all run as Administrator, SIMConnect, Direct-X Update and so on, but I will check/do it all again. My entire Sim and all downloads is located in a separate place in my file tree: C:\SteamLibrary\steamapps etc., etc. All was working before I tried to install another add-on (FS2Crew: Ultimate Ground Crew X from Just Flight). It caused a foul up that resulted in me having to uninstall everything. As far as I know I 'purged' everything to do with FSX-SE (including Steam itself), and all add-ons, before starting to reinstall 'from the ground up'. All my settings are going back as they were. Other a/c add-ons (like PMDG 737) seem to be OK but I suspect I may have one issue in the FSX-SE controllers settings / calibrations - possibly the drivers got corrupted when I deleted / reinstalled FSX-SE. I realise a lot of this is nothin g to do with Majestic and my Dash, and is only relayed for context. I'll keep at it and, if it still remains an issue with the Dash only I will raise a ticket as you suggest. Best regards, and thanks again.

  • OK thanks for the update, and keep us posted.


  • More or less fixed. It seems that most of the issue(s) were with FSX-SE and the Controller Settings randomly reassigning themselves. However, and despite following the "how to uninstall and reinstall" advice/instructions, there also seem to have been some registry entries 'leftover' after the uninstall. I sometimes wonder if it's worth carrying on with FSX, as I seem to spend more time 'fixing' rather than 'flying'. Hurrumph.

  • Thanks for the update. The remnant registry entry for the most part "should not" have affected the Q400's operation, but anything is possible.

    Moving from FSX to a newer platform is always a personal choice as one has to determine how much more money will have to be invested (hardware and software wise).


Sign In or Register to comment.