Selected altitude knob and V/S do not operate properly

Hello everybody, hoping you had a nice Xmas.

As I had a bit of problems with P3dv5, maybe due to so many addons or Win 10 updates, I uninstall and reinstall everything with Admin rights.

MJC Q400 Pro 1.021 64 with the 125 Hz - CPAN Multimedia
Only stock airports
Driver Nvidia updated 427.29
Active Sky P3D
Aviaworx for the FMS
Navigraph FMS only

I have also MFSF 2020 on that computer. I wont comment on that one. Does not look quite ready yet for the Q400.

No other program installed as the computer is only for Sim.

My problem: I cannot set the altitude, nor the V/S; it goes up and back to "0" for the V/S and to any altitude never above 2000 Ft when trying to set the altitude. This is the same on the ground or in the air unless I pause the Sim.

I uninstalled and reinstalled few times P3d and the MJC Q400 with the same result.

Thank you if you have an idea as it is not very simple to work the Q400 that way and I am starting the Aerosoft Arouind the World in 80 days managing my first leg EGKK to LFPB with great difficulties.

Kind regards,



  • Hello JP,

    Season's Greetings! The issue that you seem to be having may be related to the units setting with the simulator.

    Changing them to reflect feet+inches or feet+millibars should rectify the issue.

    Keep us posted.

  • Hi Simeon,

    You made my day.

    Problem solved.

    When you imagine that I am struggling with that problem since the last three days.

    You are my private Father Xmas!

    Thanks again and God bless.


  • Good to hear you are back on track..

    GOD bless you too.
  • I'm having the same problem since I bought the aircraft and I never managed to give it the V/S and IAS I've done everything I even gave up, coming back here and saw this post but it still doesn't work, strange it only happens with this aircraft maybe one update to resolve issues

  • Can't put out an update to some that is not broken.

    Can you elaborate more on your issue as the issue mentioned in this post has a fix which is mentioned and once a adjusted by the affected use it corrected the issue.
  • edited January 2022

    My problem is that it does not give the V/S and the IAS as it is in the photo , I put it up or down and it does nothing

  • Unfortunately, I am unable to read the message after the VS. There should be anything preventing you from selecting IAS or VS as such. And I take it that if you choose IAS it does not change to the desired mode.
  • It changes to the desired IAS OR VS , only that both do nothing when I go to the button up or down the wheel button but does not change anything is always with these 4 traces

  • Was with version 5.3 hotfix 1 i went back to 5.3 without hotfix and it was good

  • edited January 2022

    P3D v5.3.0.0

  • I performed several tests using the latest update from P3D including the HFs and had no issues using VS or IAS for climbs and or descents.

    My recommendation would be is to uninstall and reinstall the aircraft, and be sure to use Admin right to do so.
  • I don't understand what aircraft this is now I regret it stopped working again, I give up on the aircraft it's a pity to run out of money it was the worst spent money I've ever spent GARBAGE

  • Good luck to all

  • Hi,

    Comparing your pictures for and the one with the hotfix: On the first picture you did not activate the autopilot, while you did it on the second picture (showing "AP").


  • Because when I'm active the AP is the same thing as not having the aircraft goes crazy and disconnects soon

  • and now ran out of sound lol ,it's just problems this aircraft already uninstalled

  • When you installed the aircraft are you also installing the associated simconnect installer that is supplied as part of the installer?

    In your case images alone are very likely not going to be adequate to assist. Can you create a video to show how you setup prior to take of and then the steps you initiate for the intended operations.. Which fail to work.

    Thank you
  • edited February 2022

    I've done so much installation that it doesn't let you install any more

    Yes I install everything i have to install until I open the file in admin , all in Admin

  • I only did a couple more flights , I have already uninstalled and I will not install again this aircraft is wasting time and losing money , for me can close the Topic

  • If you need to have the installations reinstated, then send an email to our Support Dept. With the following 4 items:
    1 Full name
    2 Email used for the purchase
    3. Vendor from which purchased
    4 Order number

    Also provide an explanation why the installations became exhausted and or attach this link with discussions.

    You are the ONLY person with this issue (at this time) so it could very well be some of the following.
    a). A self induced issue
    b). Something with your setup
    c). A third party addon

    It is a bit odd that it worked with the first release of 5.3 but them the hot fixes cause issues so there has to be something that may have changed but if so it should be affecting more users.
  • Well, I don't know what's going on, of all the aircraft I have since PMDG, Fslabs, aerosoft and QualityWings among others I've never had problems with any of them and a Thank you but enough for me I've already lost more money and time with an aircraft that has more problems.

  • Lardinis, looking at the FMA (flight mode annunciators) at the top of the PFD, I see you have flight director modes selected but that TCS is enabled. TCS essentially bypasses the autopilot and allows the pilot to hand fly with the autopilot engaged. This is often to make adjustments without having to adjust these parameters through the flight guidance panel (FGP). With that being said, the TCS button is pressed and held, the adjustments are made and then the TCS button is released. It looks like in your case, it is continuously engaged which would allow you to turn on the autopilot, but it’s bypassed and the pilot is flying the plane.

    In your .ini file for the Q400, is TCS assigned to a button on a joystick? If it is, go in and delete that entry or assign it to a button that is a momentary switch.

  • It's a pity for the aircraft but I can't do anything else, I had already uninstalled it and now I can't install it anymore I'm tired of this aircraft, thank you very much for the help but I'm without it it's very strange sometimes it goes well and sometimes it goes wrong and I always do the same, thank you very much

  • You’re right it is a pity. I have 3000 hours in Dash 8’s in real life, have been swimming for 20 years now and this is the most accurate add-on that I’ve ever flown in flight sim. Systems, sound, handling, all of it is nearly 100% true to real life. Only other thing I’ve flown that gets close is the FSLabs Airbus but with its terrible frames and the fact that it seems to manage to break every chance it gets the only airplane I will fly is the Q400.

    I would encourage you to try once more, as you are truly missing out on a great airplane.

  • Yes, maybe you're missing a big plane or not, I just know that I can't fly now I made two flights and that's it, I've seen video tutorials I did everything like a flight plan on YouTube and mine can't fly, for so I don't think I'm missing a good plane because if it was good I wouldn't have so many problems, here on the forum there are no shortage of problems and mine is one more
  • edited February 2022
    That is the purpose of a forum. To discuss issues that may or may not exist with the aircraft or simulation platform.

    The product is not perfect by any means and there a few bugs which we are currently working on. But our of the box the aircraft once setup correctly will work. Comparing the MJC Q400 to other aircraft that you use really holds no worth as they are each designed differently and they too have bugs/issues that are not perfect.

    Since you are not willing to provide a video of steps you take and or are willing to take some of the advise/help being offered, I am not sure how much more help we can offer.

    Conducting two flights which are problematic can be frustrating, but we need to understand what it is that you are doing incorrectly and or what configuration issues may be present causing issues.

    You have provided some images which made it possible to observe that certain conditions were present preventing specific functions of the autopilot . Regardless of watching other tutorials if your set up is not correct you certainly can not expect the aircraft to operate as it should.

    @q400sim has indicated that your TCS (touch control steering) is active, and thus overrides the autopilot when activated for temporary flight adjustments. It is very possible that this is active in the mjc84.ini for which you have a button on your yoke or joystick that is causing the TCS to be activated.

    I would suggest having a look in the mjc84.ini and removing that line which is under anf also if the autopilot may be cause issues then you can reassign it as well.
  • kroswynd, you solved my problem , first installed the aircraft without messing with anything and the problem continued then I closed the simulator and removed only the two line you mentioned and I opened the simulator and stayed to work 100% a thank you no longer knew what to do , now just fly , thank you kroswynd

  • You are welcome
  • Again thank you kroswynd

Sign In or Register to comment.