TRAINING EDITION - Problem setting ILS Course using Left Hand Course Selector

Since acquiring the Training Edition, I’ve been having a problem setting the ILS course setting when using the Left Side course selector on the AFCS panel. During descent, I bring up the NAV CDI pointer on the MFD by pressing and holding the FORMAT button. When I try setting the ILS course using the Left Side course selector, the selector moves (i.e., rotates) but the NAV CDI doesn’t move nor does the displayed course setting change so I am unable to set an ILS course setting. I can get around this problem by setting the ILS course using the Right Hand course selector which works (i.e., the NAV CDI pointer moves and the dialed in course setting is correctly displayed. On final approach, rather than selecting NAV1 on the Captain’s side, I select NAV2


  • edited February 2022

    Unfortunately, i´m experiencing the same issue, but in my case, it´s the "PRO Edition" 1.024,
    Never had problems with previous versions. P3D4.5 HF3, Win10 (fully updated)

  • Well - I thought that this was really strange so I tried my desperation move - uninstall and reinstall and the problem disappeared!!

  • I ran a test on all versions PRO/TRAINING/COCKPIT and was not able to replicate the issue.

    @jpavey11 Thank you for taking the initiative to uninstall and reinstall. Good to hear that the out come corrected the issue.

    @GCRR There is a good possibility that an Win update may have caused issues. I would also recommend uninstalling and reinstalling the Q400.

  • @kroswynd That´s what i already did. I ipdated Windows, uninstalled the Dash completely, rebooted, installed version 1.024, then encountered the mentioned issue. So i did the same procedure : uninstalled rebooted, reinstalled from scratch and again the same issue. Finally i got rid of version 1024 and reverted back to 1.021 and it works flawlessly. Very strange indeed, i know, but i don´t want to keep on re/installing, as i will certainly run out of activations.

  • @GCRR
    There very likely may be something specific to your setup clashing with the Q400 (hardware binding or software). I suspect that we would have quite a few more complaints here and or on other forums/groups. I would suggest when you have a moment reinstall using Admin rights and if possible record a video of the event.

    If the installations become exhausted simply do a search on the forum for getting them re-installed

  • edited March 2022

    Thanks Kroswynd, i might have an idea of what could be causing the issue, will do more tests and reinstall latest version during this weekend. I´ll let you know.

Sign In or Register to comment.