HUD symbology disappearing and Coarse trim

Please can you advise on the following.

When flying through cloud with the HUD active, the HUD symbology fades in and out with thickening clouds rather as does the aircraft in spot view. Is there a fix please or am I doing something wrong?

Also, I can only trim in very course amounts, i.e. I get a HUGE trim change with every press of the button on my joystick making fine trim on an approach impossible. Once again, am I doing something wrong?

Using 64 Bit Pro version in P3D v4.3

Thanks in advance.

Comments

  • edited January 21

    @LeeSteventon said:
    Please can you advise on the following.

    When flying through cloud with the HUD active, the HUD symbology fades in and out with thickening clouds rather as does the aircraft in spot view. Is there a fix please or am I doing something wrong?

    In most cases having a high BLOOM setting can be the main cause of this issue.

    Also, I can only trim in very course amounts, i.e. I get a HUGE trim change with every press of the button on my joystick making fine trim on an approach impossible. Once again, am I doing something wrong?

    Using 64 Bit Pro version in P3D v4.3

    Have you checked your trim sensitivity settings? If not scaling it back to medium or low would be a better selection. This statement is based on the fact that one does know how you have your input devices configured.

  • edited January 21

    I think I sorted the trim. It was set on full repeat. Taken that off and will check on next flight.

    Bloom is set at zero. Any other ideas re the HUD please?

    Thanks.

  • Have you tried turning HDR off to see if that makes a difference?

Sign In or Register to comment.