Losing Sound

Yes, I have searched these and other forums for this apparently somewhat common problem.
Yes, I have applied numerous suggested remedies, including updating my audio drivers, various stuff in the Windows audio settings, ensuring the main playback devices are correct, assigning playback via the CPAN to either the mapper or the correct outputs directly and lastly reinstalling the Q400.
Yes, I am updated to the most current version of the Q400 on Windows 10 in FSX:SE.
No, none of that provided any substantial improvement. I don't know why this is an issue now - this never happened until a few days ago. In the process of switching to and setting up a new joystick, somehow this sound problem came up. It does NOT affect FSX as a whole as environmental sounds like rain will remain there and no vanilla aircraft are affected by this disease as well.

Sound will work from loading a flight up to 15 to 60 minutes in. At some point, all sound WILL cut out and nothing will be left. No main and no headphones playback. The DASH-8 will be completely silent and nothing can be done to bring back any sound. There is nothing in particular that triggers it, it happens in random situations at random times. On the shortest of trips I might get lucky and get on the ground before I lose sound, other times it disappears before I've even started up an engine.
This is really a problem. Without sound there's no joy in flying the aircraft at all. I've spent the past four days trying to troubleshoot this and it's extremely frustrating at this point.

Comments

  • So I also contacted support directly about this but as I don't want to spam you guys there with my updated findings, I'll just add to this thread. Maybe this will help get to the root of the issue or help someone with related problems find the cause of theirs.

    In troubleshooting I've noticed a rather interesting situation: FSX can't use the "Default Primary Device". If that's set in the options, FSX doesn't generate any sound. If I manually tell it to use the desired device, it will work fine. This applies to the Q400 as well: Using the default mapper yields no sound whatsoever. Manually mapping main and hp to the 1 and 2 outputs respectively will work for 15 to 60 minutes. The devices are set correctly in the windows audio options and windows itself has no problem using them correctly. I let FSX rebuild its .ini and confirmed the IDs of the devices it states in there are correct, which they are, but it still can't make use of the link.
    Another clean reinstall of the audio drivers didn't fix that. Weirdly this also wasn't the case a couple of days ago until when FSX had always been set to the default primary device and it worked just fine, Q400 included. So while I did nothing to change any audio settings on this machine before it started breaking, I'm beginning to suspect something outside of the Q400 to be the actual culprit here. I happen to have some usb devices lying around with audio processors I could use to circumvent this questionable onboard stuff and see how that goes - if only I wasn't out of USB slots at the moment...

  • I am going to go on a limb here, but did your Windows 10 go through an update recently. I was slightly perplexed a few days ago with my Simulation platform a few days ago as well when all of my sound setting seemed to be readjusted or missing in some cases. While this may not be the cause in your case, have a look at your sound card to ensure that 5.1/7.1 speaker configuration is not selected "if you do not have a 5.1/7.1 sound configuration".

    There however could be a user induced issue if you are using a tweak implemented via the Prepar3D.cfg: Set HideInfoText=0 in the Prepar3D.CFG file. Currently this setting can not be used with our Q400 as it causes several issues, sound anomalies being one of them

    Keep us posted

    cheers

  • Thanks for the input. Speaker config seems to be fine and I'm not using Prepar3D, I'm on FSX:SE.
    There is a CMJCBaseErr file that states:

    CSoundSystem:CreateMasteringVoice fail; 88960001,

    which your mate at support suggested would indicate an issue with DirectSound. Trying my best to look into that at the moment. I'm fairly certain I have a system issue here surrounding the audio drivers, seeing as how the default mapper doesn't work at all and neither FSX nor the Q400 will play anything anywhere when told to use that. That can't be a good sign...

  • Welp, to keep you posted: Trying the Q400 output on an external device was a wash because I couldn't link it there. Neither via mapper nor any combination of manual mapping would it play sound there. So I decided it was probably time for a windows restore anyway and wiped the drive to start over. I'm gonna go ahead and install nothing but FSX and critical addons including the Q400 at first later today and then take it from there. I hope you guys can tell how fond I am of your product to go through all this for it... ;)

    But just to clarify, and out of curiousity, the Q400 will always need functioning DirectSound because it uses that to synthesize, is that correct? So disabling MS Wavetable Synth will not affect it anyhow? Because for various reasons I like that to be disabled. And it technically wouldn't matter what audio driver outputs the Q400 if DirectSound is faulty? As that would explain why I couldn't map the Q400 to any external device.

  • And so it happened again. Worked fine for about two weeks now, now for no apparent reason the issue starts surfacing in exactly the same way as before. It also creates the same BaseErr log.
    Any help?

  • The log is created when there is a problem preventing the Q400 from loading correctly.

    Have you researched repairing your Direct sound functionality within your operating system as this seems to be you possible issue.
  • I have, but the result is pretty much that there is none. Running Windows 10, Direct Sound is somewhat baked in, that's why I ended up resorting to restoring the entire OS, but this still happens.

  • Okay, after long last, I have found a "fix" it seems. The audio dropout appears to not happen if both Q400 outputs are directed to the mapper. This will lead to headphone sounds playing on my speakers which isn't sweet, but at least it works this way and maybe that's gonna be interesting info to anyone with similar problems. With both outputs going to the same device I can run the sim for many hours without losing the Q400's audio. If I split them, without fail the audio will cut out completely at some point.

  • edited October 2020

    Just bumping this because I've seen some similar threads pop up while I was gone, so by now it's clear I'm not the only one affected.

    The issue remains if outputs are split. If all audio is sent to the same output, sound stays. If I want headphone sounds to a different output, all sound will fail. This is tested using several different audio cards and drivers.

    It would really be nice if you guys at Majestic could take another look at that because subjectively, the immersion drop is quite notable when having to send everything to the speakers and I'm sure you didn't program it to allow for splitting the outputs for that to end up being unusable.

  • Please contact support@majesticsoftware.com for assistance regarding this issue

  • Meh, I did that way back when I first encountered this problem and support wasn't able to find a solution, their diagnosis was that it was probably a DirectSound issue within my Operating System, which I am inclined to agree with. It just can't be fixed.

  • Copy, well there isn't much more than we can offer support wise. At this time, our apologies. Have you used the cpan sound page to assign. Sounds to specific channels based on sounds devices installed?
  • I have, I've tried all sorts of unholy combinations. The only thing that I can consistently replicate is that when the two outputs are the same, all sound will definitely be fine. It doesn't matter which particular output I choose, as long as it's the same one. All sounds to speakers works fine, all sounds to headphones works fine. And just as consistently, whenever I send them to different devices, i.e. general sounds to the speakers and headphone sounds to the headphones (or vice-versa, really doesn't matter), all sound will fail after a varying amount of time in the sim.

    If I set one of them to the "Mapper", as in the Default device, and send the other one there, too, but via selecting the device's number manually in cpan, no issues.
    If I send one of them to the "Mapper" and then the other one to a different device using cpan, yes issues.

    Tried with my PCs internal sound device, tried with two different USB devices with their own audio cards - always the above.

    Couple months ago we somehow wound up at the conclusion that it's DirectSound related, which obviously makes sense if that's what the airplane uses to synthesize. An OS reinstall didn't resolve it and accessing DirectSound on its own is all but impossible on Windows 10, it's baked in really hard. Audio drivers of varying ages didn't change anything either. It's really mysterious.

Sign In or Register to comment.