A few issues I have with Q400

I have a few issues I'm encountering with Q400 on a regular basis and I'd like to know if those are bugs or maybe I'm doing something wrong.

  1. From time to time, let's say every 10th flight I experience a mysterious issue with ailerons. They are stuck, not moving at all and no matter what I do they don't move, so I can't even taxi. It's not the gust lock! They simply don't move despite the fact P3D is getting the inputs - I checked this with FSUIPC and MJC Control Panel. It's quite frustrating to realize after 30 minutes of going through FS2Crew checklists, GSX boarding and all that stuff that you can't even taxi. The only "solution" I found for this issue is to restart P3D. Bad solution. So, is this a bug or can I actually do something to unstuck the ailerons?

  2. Managing doors in FMS makes no sense.. I press first button, second door close, I press second button first door open, ... after randomly pressing door buttons in FMS finally all doors are open/closed. Bug, feature?

  3. X-fill flight plan on copilot side. If I change flight plan on pilot side, let's say enter an approach, and than do X-fill the flight plan on copilot side the flight plan does not update on the copilot MFD. Bug, feature?
    Other than that, amazing plane, I fly it almost every day lately.

P3D v4.5 HF2, DASH 8 Q400 PRO EDITION 64BIT P3D.


  • Would it be better if I make 3 forum posts for each issue?

  • Hello, I don't think so, but some questions are difficult to answer. Of course you can speak up, then I would say to the second question, yes, I do that every now and then, but what does that help you? I can not confirm question 3, had no problems yet. Question 1, I do not have P3D, but now and then in the FSX, after using a (only which) other aircraft type, e.g. all assignments of the dash changed, must be reset. I don't have a full version of FSUIPC or an FS2Crew

  • I'm a bit confused by this answer.
    Question nr. 1 has absolutely nothing to do with either FSUIPC or FS2Crew. It's an issue I get with MJC Q400, regardless mentioned products. So nr. 2 is a bug. Ok.
    The reason for my post is simple - I just want to know if I'm doing something wrong and correct this or are those bugs and it's pointless for me to spend anymore energy and time to try to solve them.
  • Hi Tomaz,

    1- Did you check that you have hydr press after starting engines when you have this issue?

    2- Yes, there is something wrong with the AFT PAX and SERVICE. However FWD PAX and AFT BAG are OK. What I do is to open the FWD PAX first and then the AFT BAG and to close I start with the AFT BAG and it is OK all the time. Before opening or closing a door you have to wait that the first one you activate has fully finished its cycle before doing the next one.

    3- When you enter a FPL on the ground from either Captain or copilot the other pilot can get this FPL/Weight/Fuel on his side with the XFILL. After you do not XFILL from one side to the other in flight. Each pilot has to enter from his side whatever he likes and that does not interfere with the other. It is a way of checking otherwise if one pilot enters one approach and if it was wrong, the other pilot would have the same error on his side.


  • 1. I think I did. What would be a scenario where there wouldn't be enough pressure if I do everything the same every time since I use checklists? Are there any random failures that mess with hydraulic pressure?
    2. Ok, I'll do that from now on.
    3. I didn't know that. Thanks!
  • Hi Tomaz,

    Same problem as for the XFILL, the data is transferred to the co-pilot's FMS but the MFD does not display the flight plan.

    My thing, make a DTO of the first waypoint on the co-pilot's FMS and the flight plan will be displayed on the co-pilot's MFD.

    Thanks to Jean-Pierre Guenard for this tip ...


  • @cridel said:
    Hi Tomaz,

    Same problem as for the XFILL, the data is transferred to the co-pilot's FMS but the MFD does not display the flight plan.

    My thing, make a DTO of the first waypoint on the co-pilot's FMS and the flight plan will be displayed on the co-pilot's MFD.

    Thanks to Jean-Pierre Guenard for this tip ...


    I tried it. It works!!! It's not ideal but it's a solution I can live with.
    I guess this should be put under bugs than!

  • @TomazDrnovsek
    1. Your issue is a bit odd but I too have experienced this under the following circumstances, not saying they may be applicable to you. You failed to mention what control system you are using. Are you using the 125Hz control system? If not disregard.
    A. A loose connection for the input device which is quick resolved by unplugging and reconnecting.
    B. A possible corrupt fsuipc.ini, this drove me bonkers for a while I on a whim i decided to remove the fsuipc.ini and let the sim rebuild it. Rather than copying the previous entries into the ini I reconfigured all input devices.
    C. If you are using the 125Hz configuration ensure that all input devices are correctly assigned in the mjc84.ini. Also you certainly want to ensure that P3D controls are disabled to avoid conflicts.
    D. Not sure how you are initially loading the Q400, but it is recommended to not load after another complex addons. Thus too has been known to cause occasional abnormal behavior characteristics.

    What I can suggest if this continues to happen save the scenario, and then reload it to see if it corrects itself.

    1. The door operation via FMS is known to have a few bugs at the moment, which we will get back too, as its not an easy fix. If you are not pleased with it you can use the default P3D key commands for opening and closing the doors. Also when you press a key for a door to be opened or closed you must wait until the door completes it cycle before pressing the next to to be opened or closed.

    2. Regarding the FMS....prepare you mind for different type of logic. When a xfill is initiated whether it be on the ground or in the air there still may be a required step or two that will have to be initiated by the copilot or Capt and in most cases a DTO the next active waypoint may be necessary to resync the FP.

    There several posts in the forum regarding Fms functionality, do a search a browse through.


  • 1.
    I'm not using 125Hz control system.
    A. Both MJC CP and FSUIPC show normal inputs for the ailerons from my yoke but ailerons are not moving, so it's not that.
    B. I can't really see this as an option either because a "simple" restart of the P3D solves the issue.
    C. P3D controls are disabled or I would have problems with all my airplanes all the time ;)
    D. I choose the airplane in the P3D startup screen. I know it's recommended for complex addons to first load something default but I just didn't get into the habit of doing that ever and until now I didn't have any issues with any of my complex addons in like 20 years. But I never load Q400 after I loaded some other complex addon.
    Next time I'll save the scenario and try that.
    It's not a game-breaking issue but it is a pretty annoying issue.

    I'll do the sequence JP suggested. Again, it's not ideal it doesn't do what one expects it to do but it's not more than a nuisance.

    I tried with DTO and it worked.

    I'm pretty happy with the answers, at least I know how things stand and I won't be bothered by not knowing what's the matter anymore.
    Thanks again to everybody!

  • Hello, I also experienced problem 1 and 2. Of the 10+ flights I made with P3Dv4.5, around two times I also had the ailerons (and tiller on ground) stuck after initial loading, and calibrating the inputs, switching them on and off didn't help. I either had to restart P3D or simply reselect the MJC400. Note that I never experienced this issue with FSX or P3Dv3. Can you give a recommendation on how to avoid this issue?

    And as far as opening doors via FMS, I also find it annoying that pressing a specific LSK button opens or closes a different door. I hope that this issue will be fixed ASAP.

Sign In or Register to comment.